System Error…..or User Error?

Shawn Wallace, Applications Engineer, EDAX

Error Message 2

Over the past week, I have been helping our engineering department test some new hardware setups.  As the new(ish) guy, this was a pretty different aspect of the job for me. I expected to run in to some issues and I did. A conversation I had while troubleshooting one of these issues made me think of troubleshooting, not just for our systems but the process as a whole. It made me realize that even the most seemingly difficult issues often are not. They are just more difficult because of assumptions or lack of complete information.

I shall start this with the backstory that started me thinking about this blog post. I turned on a newly installed system and prepared to run through the new system calibration procedure, but something was not right. I was getting some counts, but not enough. I checked firmware. I checked cable connections. I checked microscope settings. I turned on the IR camera. All of these should have given me a signal. Something to help me troubleshoot, but I was getting nowhere.

At this point, I could have spent another hour fiddling, but there are people here who know more about things than I do and I could save myself time and grief by asking them for help. The first person I asked was Jens, our EDS expert. He knows the ins and outs of these systems. Maybe, there was something obvious I was missing.

He looked at the cables, checked the microscope settings, turned on the IR camera. Basically, he did everything I did. He was following the same troubleshooting steps I was. He was trying to isolate the problem and understand the root cause of why we were not getting a signal and just like me he was not getting anywhere.  At this point, we could have spent another hour fiddling with things, but just like before, we know there are people here who know more than we do and we could save ourselves time and grief by asking for help.

We brought over one of the engineers, a gentleman with over 23 years of experience at EDAX. One of the many people here, who have decades of experience on all aspects of our operations. He looked at the cables, checked the microscope settings, turned on the IR camera. He did basically everything we did. It was pretty validating to see someone with his experience going step by step through the same processes to understand the problem. At this point, he was semi-stumped too. Our conclusion seemed to be that a part was malfunctioning, but he had just tested it before it was mounted on our microscope.

It was the end of the road. He did not really have anyone else to turn to. So he checked his assumptions.

He started with the cables. He knew both the detector and the box had cables to them. One end in the detector, the other in the box. Right? He followed the cable from the detector backwards and much to my chagrin, the end of that cable was not connected to anything. I took the cable from the box and followed it to its obvious conclusion… it was not plugged in. We had two cables going nowhere when there should have been one cable. At this point, I may have muttered something under my breath. How did I miss that? I had just wasted two people’s valuable time on something simple. What slipped through the cracks?

That night I evaluated myself. I had started with the assumption that the system was installed correctly. It wasn’t. I had checked thoroughly enough I thought, but not closely enough. I had assumed that since both ends of a cable were in the right spots, it was connected correctly. I was wrong.

Then I started to think about what I could learn from this and how it relates to how I deal with both issues and customers. It made me realize that I often start with knowing that my customers are starting with their own assumptions. We often ask the most obvious questions at the start. Is it plugged in and turned on? I challenge those assumptions with the customer and I know often they are ignore or glossed over with a terse “yes”. Of course it is on and plugged in!

Of course, it was plugged in. I checked it myself. Words I had said to myself earlier that day. And yet, here it was not plugged in. It took the wisdom of experience for our engineer to challenge his own assumptions and double check. One day I hope to be that wise.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s